package/sent/PKGBUILD
2023-04-12 02:40:59 +02:00

31 lines
647 B
Bash

# Maintainer: DEBUCQUOY Anthony <Debucquoy.anthony@gmail.com>
pkgname=tonitch-sent-git
pkgver=1.r8.882d54c
pkgrel=1
pkgdesc="sent presentation tool with patch for tonitch"
arch=('x86_64')
url="https://git.herisson.ovh/tonitch/sent"
license=('MIT')
depends=()
makedepends=('git')
provides=(sent)
conflicts=(sent)
source=("git+$url")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/sent"
printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
cd "$srcdir/sent"
make
}
package() {
cd "$srcdir/sent"
make PREFIX=/usr DESTDIR="$pkgdir/" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}